Results 1 to 9 of 9
  1. #1
    Join Date
    Apr 2019
    Posts
    5

    Question How to stop Tree from expanding a feature after double-click?

    When I double click on a feature to examine or change it, the tree expands that feature to show the sub-features or parameters. For example, if I double click on a Sweep, it automatically expands it in the tree to show the parameters associated with it (Lenght1, Lenght2, Angle, etc.). How can I prevent this from happening?

  2. #2
    Join Date
    Jul 2006
    Posts
    1,722

    Default

    I don't think you can change that. It's just the way CATIA works.

    •   AltAdvertisment

        

  3. #3
    Join Date
    Apr 2019
    Posts
    5

    Default

    Thank you for your answer. Hopefully somebody has found or will find a tweak for this and they can share it here!

  4. #4
    Join Date
    Jul 2006
    Posts
    1,722

    Default

    I did a google search and came up with two possible solutions for you: (maybe you have already tried them?)

    First, Tools + Options + General + Display + Tree Manipulation and turn off Automatic Expand

    If that doesn't work, there's a Expand/Collapse command that will collapse/expand the tree. In the link below (scroll down a little bit), they added this command to a new toolbar and just click on this icon to change the tree.
    http://www.maruf.ca/files/caadoc/CAA...leSpecTree.htm
    Last edited by MrCATIA; April 5th, 2019 at 03:49 PM.

    •   AltAdvertisment

        

  5. #5
    Join Date
    Apr 2019
    Posts
    5

    Default

    Quote Originally Posted by MrCATIA View Post
    I did a google search and came up with two possible solutions for you: (maybe you have already tried them?)

    First, Tools + Options + General + Display + Tree Manipulation and turn off Automatic Expand

    If that doesn't work, there's a Expand/Collapse command that will collapse/expand the tree. In the link below (scroll down a little bit), they added this command to a new toolbar and just click on this icon to change the tree.
    http://www.maruf.ca/files/caadoc/CAA...leSpecTree.htm
    Thank you! I did try turning off the Automatic Expand option, but it does not work.

    The second solution could work, but if it collapses the whole tree, it's not ideal since I want to keep seeing the features inside a certain Geometrical Set or Part, just not the parameters inside those features. It might be faster to collapse all and open the specific Geomtrical Set again than manually collapsing each feature, though!

    Thanks again!

    EDIT: I just read the link and it seems it could be an useful feature, but I need to ask my System Admin to make those changes.
    Last edited by ignrolfer; April 8th, 2019 at 05:44 AM. Reason: Added comment.

  6. #6
    Join Date
    Mar 2018
    Posts
    9

    Default

    I think if you don't need surface properties, you shall create it in Datum entity with the icon among icons below. First turn on the button and then you can create the geometry by any command in datum status.

  7. #7
    Join Date
    Jul 2006
    Posts
    1,722

    Default

    I have to disagree with you Sanam. Working in Datum mode (to isolate every geometry you make) is a bad practice, since nothing can be edited.

  8. #8
    Join Date
    Mar 2018
    Posts
    9

    Default

    Yes, you're right, and I know that, so I pointed that ,if this dear friend doesn't need surface properties ,I mean, editable properties of the surface, ...
    This way is just for cases one wants to design a model for a representation like cgr format to save to represent,otherwise it's not a good way.Maybe I should write this point at the first reply. Thank you for your attention.

  9. #9
    Join Date
    Mar 2018
    Posts
    9

    Default

    And an other point which must be considered:

    click once on the button not more times. as far as I know if one clicks on more than once, this mode will be permanent.

Tags for this Thread

 

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •