Welcome to 3DCADForums

Join our CAD community forums where over 25,000 users interact to solve day to day problems and share ideas. We encourage you to visit, invite you to participate and look forward to your input and opinions. Acrobat 3D, AutoCAD, Catia, Inventor, IronCAD, Creo, Pro/ENGINEER, Solid Edge, SolidWorks, and others.

Register Log in

Catia V5R19 SP2 W32: errore ScriptingERR_1004

It 's the first time I place a new discussion as this precious forum is a great tool to learn about, explore topics, as well as untangle skeins inherent in CATIA. After developing my skills with the various modules I decided to throw in the development of my macros to automate procedures, especially in the case of parametric design, editing components CATPart. When I run each macro, whether in CATScript format or MS VBScript, CNEXT produces the following error dialog:

Cnext - CATScriptErrorMessages: ScriptingERR_1004
Execute the script: "*.CATScript"
CATScript scripting engine is not properly installed.
Install the scripting engine and run the script again.

In the case of *.catvbs macro the error message is more or less like this:

Cnext - CATScriptErrorMessages: ScriptingERR_1004
Execute the script: "hellomsg.catvbs"
MS VBScript scripting engine is not properly installed.
Install the scripting engine and run the script again.

Convinced that it was a problem related to an improper installation of CATIA I tried to install other versions and SPK of CATIA but this problem is not solved.

At this point I inquire of you more experienced users of the forum and your experience of how to solve this huge, for me, issue.

My setup is as follows: Microsoft Windows Vista Home Edition 6.0.6002 (WinVista Beta) - Intel Pentium III Xeon, 2000 MHz (2.5 x 800) NVIDIA GeForce 9600M-GT-RAM 4 GB-232 GB HD, IDE.
Catia V5R19 SPK9

Thank you in advance for your help!


Here is the video related to error of msgbox "Hello..." macro:
 

Sponsor

Top