Welcome to 3DCADForums

Join our CAD community forums where over 25,000 users interact to solve day to day problems and share ideas. We encourage you to visit, invite you to participate and look forward to your input and opinions. Acrobat 3D, AutoCAD, Catia, Inventor, IronCAD, Creo, Pro/ENGINEER, Solid Edge, SolidWorks, and others.

Register Log in

disappearing geometry

halzimers

New member
I am seeing my geometry disappear......any ideas?

I have everything drawn correctly and then somehow the part
doesn't show up in the catia session. Everything is still in the
tree and the sketches can be accessed.

Hide/Show does absolutely nothing.

It has happened with a few models, even drawing from scratch.

My parts are invisible! Help!
 

MrCATIA

Super Moderator
Could be many things that are causing this problem, Halzimers,

(now that I have CATIA running in front of me, I will re-write my original post)

a. Look at the View toolbar dropdown and make sure the Geometry item is checked

b. Look carefully in the tree for icons that are grayed out (hidden). Might be the part at the very top of the tree that's hidden. Might be the Part Body that's hidden. Do you see anything when you Swap Visable Space?

c. Use the Graphic Wizard to analyze the last feature you made to check the Show status of this feature and everything above it

d. Check to see what is the current work object (what's underlined). Make the Part Body containing the geometry the Define In Work Object

e. Check the Tools + Options + Infrastructure + Part Infrastructure, Display tab to see if you have the Only Current Body turned on. Uncheck this option to see all bodies

If none of these help, please attach a capture of the CATIA window, including all the toolbars and the tree , and we'll try to pinpoint the problem.
 
Last edited:
Awesome

Could be many things that are causing this problem, Halzimers,

(now that I have CATIA running in front of me, I will re-write my original post)

a. Look at the View toolbar dropdown and make sure the Geometry item is checked

b. Look carefully in the tree for icons that are grayed out (hidden). Might be the part at the very top of the tree that's hidden. Might be the Part Body that's hidden. Do you see anything when you Swap Visable Space?

c. Use the Graphic Wizard to analyze the last feature you made to check the Show status of this feature and everything above it

d. Check to see what is the current work object (what's underlined). Make the Part Body containing the geometry the Define In Work Object

e. Check the Tools + Options + Infrastructure + Part Infrastructure, Display tab to see if you have the Only Current Body turned on. Uncheck this option to see all bodies

If none of these help, please attach a capture of the CATIA window, including all the toolbars and the tree , and we'll try to pinpoint the problem.
I almost lost my hope doing your answer from 'a' to 'd' point, but then your 'e' answer is AWESOME !! Thanks Mods. Cheers
 

MrCATIA

Super Moderator
in the case of solution "e" above; this can accidentally happen very easily. In the Part Design workbench, there is a small icon that can set the Only Current Body display. It's the icon that is immediately to the left of the Catalog Browser icon, and clicking this icon will change display modes without having to use Tools + Options.

  • If the icon shows 3 blue rectangles, then all the Bodies are displayed.
  • If the icon shows 1 orange rectangle, then only the Current Body (the defined Work Object) is displayed.
 
Last edited:

ckl51hut

New member
Could be many things that are causing this problem, Halzimers,

(now that I have CATIA running in front of me, I will re-write my original post)

a. Look at the View toolbar dropdown and make sure the Geometry item is checked

b. Look carefully in the tree for icons that are grayed out (hidden). Might be the part at the very top of the tree that's hidden. Might be the Part Body that's hidden. Do you see anything when you Swap Visable Space?

c. Use the Graphic Wizard to analyze the last feature you made to check the Show status of this feature and everything above it

d. Check to see what is the current work object (what's underlined). Make the Part Body containing the geometry the Define In Work Object

e. Check the Tools + Options + Infrastructure + Part Infrastructure, Display tab to see if you have the Only Current Body turned on. Uncheck this option to see all bodies

If none of these help, please attach a capture of the CATIA window, including all the toolbars and the tree , and we'll try to pinpoint the problem.
I'm in the same situation but non of above way works. Is there anybody help?
 

MrCATIA

Super Moderator
could you please attach a picture of the entire CATIA screen, including all the menus and toolbars
 

Sponsor

Top