Welcome to 3DCADForums

Join our CAD community forums where over 25,000 users interact to solve day to day problems and share ideas. We encourage you to visit, invite you to participate and look forward to your input and opinions. Acrobat 3D, AutoCAD, Catia, Inventor, IronCAD, Creo, Pro/ENGINEER, Solid Edge, SolidWorks, and others.

Register Log in

External References Catia V5 R20

J.Johnson

Newbie
Hello All,

This is my first post so please be kind!

We recently hired a new Engineer. Anytime he creates a model it refuse to allow external refrences. His models seem healthy with this one exception. We have compared our settings and have found no mismatches. A product that contains his parts will allow ER's on all parts but the ones he has created. We are not getting an error mesage, it just will not allow us to select the geometry.

Does anyone know what could cause this issue? Could it be they way he is modeling his parts? (I dont think this is the issue, but what do i know) Or is there a setting that we missed? (I feel like this is the issue, but cant find the setting)

Thank you for you help!

~J. Johnson
 

MrCATIA

Super Moderator
Could be several things causing this problem:

Is there a error message, or any kind of indication (different cursor) when he tries to reference the other geometry?

How is he (or the other engineers) making this extrernal reference?

When looking that the Product tree, what color are the icons in front of the part instances?

Some obvious settings to check:

Tools + Options + Infrastructure + Part Infrastructure + General: is RESTRICT EXTERNAL SELECTION WITH LINK TO PUBLISHED ELEMENTS active? is USE ROOT CONTEXT IN ASSEMBLY active?
 
Last edited:

J.Johnson

Newbie
Could be several things causing this problem:

Is there a error message, or any kind of indication (different cursor) when he tries to reference the other geometry?

How is he (or the other engineers) making this extrernal reference?

When looking that the Product tree, what color are the icons in front of the part instances?

Some obvious settings to check:

Tools + Options + Infrastructure + Part Infrastructure + General: is RESTRICT EXTERNAL SELECTION WITH LINK TO PUBLISHED ELEMENTS active? is USE ROOT CONTEXT IN ASSEMBLY active?
Thanks for your reply.

Yes when trying to select his parts for externaml refrence the cursor changes to a black circle with a minus sign. There is no error message or pop up.

Generaly speaking we try to keep external refrences to a minimum with the lone exception being cable routing. We generate points and lines from the product so that when the individual parts change the cable routing will update to suit. We will create a cable part and insert it into the product, and then begin to extract geometry to supports our points and lines.

In the product the instances have the blue and yellow cogs with the little green arrow showing the part is loaded. The part itself shows shows the yellow cog. Inside of the part its the standard green cogs for part bodies and yellow geo set symbols.

Restrict External...is not active and Use Root Context is active. This is our comapny wide default.
 

MrCATIA

Super Moderator
Thanks for the response. Everything seems OK, so I'm still not sure why the new guy has the problem.

- Does the new guy have the same SEARCH ORDER as everyone else?

- Is the new guy activating the correct part? (does the part instance have a blue background in the tree? Is this the part you want to add the link to?)

sorry, more questions:

Which PDM system are you using? (ENOVIA LCA maybe?)

The Blue and Yellow cog icons indicate no EXTERNAL LINKS. Do the other engineers have the same icons in their products? (I expect to see some blue and GREEN cogs. Blue and BROWN would indicate not being able to add new External References)
Context icons.JPG

When the other engineers create EXTERNAL LINKS, do they show up in the EDIT+LINKS table as IMPORT LINKS?
 
Last edited:

MrCATIA

Super Moderator
another possibility:

Verify the new guy is not in Visualization Mode. Must be in Design Mode in order to add new External References.

Also; verify the new guy is starting CATIA correctly, and exiting correctly.
 

Sponsor

Top