Welcome to 3DCADForums

Join our CAD community forums where over 25,000 users interact to solve day to day problems and share ideas. We encourage you to visit, invite you to participate and look forward to your input and opinions. Acrobat 3D, AutoCAD, Catia, Inventor, IronCAD, Creo, Pro/ENGINEER, Solid Edge, SolidWorks, and others.

Register Log in

Geometry won't show up in drawing

Wallybanger

New member
OK, so I have this truck model and I'm trying to get it into a drawing but apparently a lot of the geometry is CGR or something and it won't load.

Is there anyway to get that stuff to show up in my drawing?

 

MrCATIA

Super Moderator
The missing parts on the drawing could be caused by several things.

  • Check the View Properties and turn on the 3D Wireframe option. If this options is not turned on, drawings are based on solid geometry only, not surface or wireframe
  • Also check the View Properties at the very bottom of the list in the Generation Mode section, and turn off both options (probably neither of these are causing the problem with your truck)
  • Check the Overload Properties to make sure the Visibility is set to "shown" for all parts in the assembly
  • If you're working with layers, make sure you have the correct Visualization Filter applied
 

Wallybanger

New member
The missing parts on the drawing could be caused by several things.

  • Check the View Properties and turn on the 3D Wireframe option. If this options is not turned on, drawings are based on solid geometry only, not surface or wireframe
  • Also check the View Properties at the very bottom of the list in the Generation Mode section, and turn off both options (probably neither of these are causing the problem with your truck)
  • Check the Overload Properties to make sure the Visibility is set to "shown" for all parts in the assembly
  • If you're working with layers, make sure you have the correct Visualization Filter applied
[*]View Properties and 3D Wireframe are not the issue. Played with that many times and it wasn't the problem. tried again just to make sure

[*]under Generation Mode neither of the boxes are checked. The interesting thing is that under Generation Mode, if I change the View Generation Mode dropdown list from Exact View to CGR, the model shows up perfectly.... however, I can't use any of the points I need.

[*]the only Overload Properties I could find was in the pop up menu after right clicking on the view and under "--- view object". It brings up an empty box that says "CHARACTERISTICS" across the top.


So it seems I still don't really know what to do....

Thanks for the help so far MrCatia.
 

MrCATIA

Super Moderator
Wally,

If you don't know, then you are probably not using Cache mode. Go to Tools + Options + Infrastructure and see if the Cache Activation is turned on. Normally, it is not selected.

("Working with Cache" is a CATIA method to improve performance when working with large assemblies. When this mode is turned on, a smaller computer image file (called a CGR and consisting of a lot of triangles) is made and cached in your computer, and this CGR is loaded instead of the larger geometry-based CATIA file whenever you open the assembly)

Back to your original problem:

You said you get all the parts when you use the CGR option for View Generation? That makes we think you are working with cache (working with the CGR)

If you do have the Work with Cache option turned on; back in the Assembly, in the tree right-click the very top assembly, select Representations + Design Mode. This will unload the CGR files, and load the geometry-based solids. Then switch the drawing View Properties back to Exact and Update the drawing. Hopefully this will project all the geometry and you'll be able to pick what you need for your dimensions.

A common problem when working with Assembly drawings is not enough memory - are you getting any error messages in the middle of the view creation or update process?
 
Last edited:

Wallybanger

New member
Wally,

If you don't know, then you are probably not using Cache mode. Go to Tools + Options + Infrastructure and see if the Cache Activation is turned on. Normally, it is not selected.

("Working with Cache" is a CATIA method to improve performance when working with large assemblies. When this mode is turned on, a smaller computer image file (called a CGR and consisting of a lot of triangles) is made and cached in your computer, and this CGR is loaded instead of the larger geometry-based CATIA file whenever you open the assembly)

Back to your original problem:

You said you get all the parts when you use the CGR option for View Generation? That makes we think you are working with cache (working with the CGR)

If you do have the Work with Cache option turned on; back in the Assembly, in the tree right-click the very top assembly, select Representations + Design Mode. This will unload the CGR files, and load the geometry-based solids. Then switch the drawing View Properties back to Exact and Update the drawing. Hopefully this will project all the geometry and you'll be able to pick what you need for your dimensions.

A common problem when working with Assembly drawings is not enough memory - are you getting any error messages in the middle of the view creation or update process?
I just went and checked it out and I'm not working in Cache Mode. I have to try REALLY hard now to get Catia to throw a memory error. I have the /3GB switch runnin on XP and I have 4gb of ram in my computer.
 

MrCATIA

Super Moderator
OK, so I have this truck model and I'm trying to get it into a drawing but apparently a lot of the geometry is CGR or something and it won't load.

Is there anyway to get that stuff to show up in my drawing?
Wally, we recently came across a similar problem with a part, but this might be why you're having problems with your assembly.

Check all the branches in the tree for deactivated items at the bottom of the branch. Apparently there is a software bug, when the last item is deactivated, the part is ignored in the drawing views.

Either reactivate the feature, delete it, or reorder it so it's not at the bottom.

Hope this helps!
 

Sponsor

Top