Welcome to 3DCADForums

Join our CAD community forums where over 25,000 users interact to solve day to day problems and share ideas. We encourage you to visit, invite you to participate and look forward to your input and opinions. Acrobat 3D, AutoCAD, Catia, Inventor, IronCAD, Creo, Pro/ENGINEER, Solid Edge, SolidWorks, and others.

Register Log in

Significant digits on round numbers

simonsp

New member
Hi,

Are there any way to set a default setting for drawings, so round numbers comes with two significant digits? -Both for the dimension value and tolerances.
E.g. 26±2 is default shown as 26.00±2.00.

I am aware that the digits is not needed, but I would like it for consistency.
Also, I do have my settings such that fractions are shown with two significant digits.
e.g. 34.54±0.05 is shown as just written.

Thanks
 

MrCATIA

Super Moderator
There is a setting for this included with the drafting standards. I'm not sure what it's called, but it either includes trailing zeros (a US method), or it drops trailing zeros (European method).

An easy way to change the setting is to choose a different Standard; File + Page Setup, and choose ANSI for trailing zeros (26.00±2.00) or choose ISO for no trailing zeros (26±2).

The number of decimal places is changed with the Precision (round-off) parameter in the top drafting window.
 

simonsp

New member
Thank you very much, Mr.Catia!
It solved my problem :)

To clarify for anybody els; You open Catia in Admin mode, go to Tools -> Standards... -> Choose "drafting" in "Category" -> Select your standard -> Styles ->Length/Distance Dimension -> Default -> Value Display Format-> Main Value -> Name -> write "ANS.DIMM".

This, of course, has to be made for all types of tolerances that one use.
 

Sponsor

Top