Welcome to 3DCADForums

Join our CAD community forums where over 25,000 users interact to solve day to day problems and share ideas. We encourage you to visit, invite you to participate and look forward to your input and opinions. Acrobat 3D, AutoCAD, Catia, Inventor, IronCAD, Creo, Pro/ENGINEER, Solid Edge, SolidWorks, and others.

Register Log in

Surfaces won't knit to Solid

Mortier

New member
Hello,

I am designing a superstructure for a yacht in Solidworks and since there is curvature in many directions a surface approach seemed the most suitable to me.

However there seems to be a gap which I think prevents me from knitting the surfaces together to a Solid. Although the gap theoretically should not exist as I used edge relations

Any one has experience with this kind of issue? I am using the Student Kit 2010 32bits.

Regards

Alex



Uploaded with ImageShack.us

 

Kevin De Smet

New member
Difficult to diagnose from screenshots. only tip I can give is try to use less fill surfaces, boundary and loft are often more accurate.
 

MadHatter

New member
Turn Gap Control off. If you are sure that there can´t be any gaps you can ignore this "feature" ;)

Should work immediatly after turning off.

I for myself never use this feature, nothing but trouble (btw, the gap analysis is heavily influenced by quality of tesselation data, so... just forget it).
 

Mortier

New member
Thanks for the replies.

I used mainly filled surfaces indeed. I will try to use boundary. I get an error when I try to use the knit command with "Try to create solid" ticked: Failure to knit faces.

But maybe it helps when I use boundary surfaces. Thanks.
 

MadHatter

New member
As I said above, turn Gap Control OFF.

Will help. If not, there is something ugly in your model, in this case: could you upload the model somewhere? I´ll have a look at it then. Or email me: [email protected]
 

Mortier

New member
Hey Martin

Thank you very much for this.
The surface know knits. I did not realize that both sides were inclined. This was not intended. I will have to sort that out.

However after I trim off that piece and I then I knit it as a solid, it still does not appear as a solid somehow? ( When I make a section view?)

I does appear under the SolidBodies tree?
 

MadHatter

New member
Hum, can´t verify this on my machine. But I know the problem, try to safe the file, close SW and start it again, most likely it´s a graphic error. You use a certified graphics card?
 

Mortier

New member
Ah it was my bad. I thought it wasnt a solid but the section cap was not turned on.

So it is a solid now, but I still have an issue, I cannot combine the two solids into one solid using Feature - Combine - Add? It says "Operation failed due to geometric condition".

Thanks for any suggestions you can give me. Note: my structure is built on a plane that lies at the aft part of the hull (called WD TS)
 

MadHatter

New member
Hi!

There seems to be some "zero-distance" somewhere in the model which makes it impossible to combine the two solids. By using the "Move/Copy" feature, you can move one of the solids a little further into the other solid body. As soon as the two bodies intersect each other completely, you can combine them (I tried it with 3mm in negative Y). This would be the easiest method, although it´s not correct and you shouldnt do this, it´s cheating.

The correct way would be to start a new approach of modeling this, taking the upper surface from the boat hull (the "deck") as a reference surface on which all other surfaces are built upon. Then combining the 2 bodies is possible. You started the second solid on a plane, this "plane" surface, together with the curvy surface of the upper deck can´t be combined this way.

P.S:

imo it would be better to use solid modeling instead of surfacing for this job. Most of this geometry could be done using linear cuts and the draft-feature...
 
Last edited:

Mortier

New member
Ah that would make sense since the whole structure is built on the aft end of the deck.

I have been thinking about using solids before but I couldnt get it to work either, but im quite a novice on all this so that might be the issue. I gave it a go and this is what I came up to:

http://dl.dropbox.com/u/4428927/example2.SLDPRT

Need to do some surface cuts on the front but that will be fine, there is a new issue though, because I used projected curves to create lofts between the "roof" and the "deck" (curved), I hope this is the right approach? :) I can only create my geometry by keeping the Merge result box ticked, but I want to leave it unticked for now because I need to shell things separately later and I need to make surface cuts on the front part as well.

I really appreciate all your support!

Alex
 

MadHatter

New member
Hi!

Still too complicated ;)

Forget the thing with the curve, use the 2D-sketch to make an extruded boss and set the end parameter of the feature to "up to surface", then use the deck of the boat to limit the boss. Easiest way, also, like this you dont need to merge the bodies...

http://www.abload.de/img/dasd2lt5.png

@ gupta: when I open your model I get nothing but rebuild errors? :(
 

Mortier

New member
Ah yes I could do that but for the bigger part, but the aft part is angled (draft) but only in one direction (thats why I used a loft), so I cant use the draft command? I dont want to end up with draft on all sides? I also get errors in gupta's file
 

MadHatter

New member
Use the draft-feature (insert, features, draft), not the draft-option in bossed features. With that you can set drafts on single surfaces whilst the geometry of the main body stays untouched.
 
Last edited:

Mortier

New member
Thanks!
Buut that still does not fix the problem entirely, the draft adds material to the outside, rather that cutting bits of. Resulting with this:

:eek:

Well I am almost there I guess :p

P.s. my method was: Neutral plane draft with the top face being the neutral plane (the bottom one is not flat), the side is of course the draft plane
 

MadHatter

New member
Almost there ;)

You can select any flat surface as the neutral face when using the draft feature. Might be a flat surface of another solid body, planes created using reference geometry and even the standard-planes (front, top, right). Neutral faces and draft faces do not need to intersect, you can use the neutral face as you like.

HTH

P.S.

donations welcome :p

*kidding*
 

Mortier

New member
Got it. Now I know how to proceed. This has been very helpful. I started feeling guilty indeed. Thanks a lot!
 

Sponsor

Top