Welcome to 3DCADForums

Join our CAD community forums where over 25,000 users interact to solve day to day problems and share ideas. We encourage you to visit, invite you to participate and look forward to your input and opinions. Acrobat 3D, AutoCAD, Catia, Inventor, IronCAD, Creo, Pro/ENGINEER, Solid Edge, SolidWorks, and others.

Register Log in

Unable to work with the object made in Generative Shape design in PartDesign

Good evening,

I am encountering a wierd problem. I made a model in generative shape design and when i enter the part design mode i am unable to do anything to my geometrical set. For example, if i want to pocket it displays a message: "The current in work object isn´t a body, The new solid feature is created after the last feature of the PartBody."

Can anybody help me?

Thanks,
Jonas de Oliveira
 

skk

New member
Hi Jonas,

If you are using Generative shape design for creating surfaces means, that's fine. But you should switch to part design workbench to create solids.

First select the body(in which you would like to create the solid feature), right click--> Define in work object. Then create the feature.

On doing this, Kindly note that Your first feature has to be a constructive one if you are creating under part body. (ex. Pad, shaft, rib etc.,). If you really want to create a 'Pocket' as your initial feature then You should insert a new body. (From the Menu bar, click Insert --> Body. Then Right click--> Define in work object.

I hope this solves your problem. If not let me know.

Cheers!!
 

skk

New member
Hi Jonas,

If you are using Generative shape design for creating surfaces means, that's fine. But you should switch to part design workbench to create solids.

First select the body(in which you would like to create the solid feature), right click--> Define in work object. Then create the feature.

On doing this, Kindly note that Your first feature has to be a constructive one if you are creating under part body. (ex. Pad, shaft, rib etc.,). If you really want to create a 'Pocket' as your initial feature then You should insert a new body. (From the Menu bar, click Insert --> Body. Then Right click--> Define in work object.

I hope this solves your problem. If not let me know.

Cheers!!
 

Sponsor

Top