Welcome to 3DCADForums

Join our CAD community forums where over 25,000 users interact to solve day to day problems and share ideas. We encourage you to visit, invite you to participate and look forward to your input and opinions. Acrobat 3D, AutoCAD, Catia, Inventor, IronCAD, Creo, Pro/ENGINEER, Solid Edge, SolidWorks, and others.

Register Log in

Weirdest scaling problem with saving as DXF.

PetriT

New member
Hi,

I have one really frustrating problem with my Catia V5.
This is hard to explain so I made a short video of it.
https://www.youtube.com/watch?v=SXtsWoPzXKg
Hopefully you get the idea from that.

Problem is with scaling when I save a file as dxf and then open it again.
Happens rarely (4 times out of ~200 files I have checked this week).
Always simple shape causes problems. More complex shapes are saved normally.
At the moment I have tried 3 hours to create a dxf-file that has only one ø21,0 mm circle in it (no success).

I have tried:
1. Restart Catia
2. Restart Computer
3. Check different settings
4. Delete AppData personal settings

Same happens with DWG files too.

Regards,
Petri T
 

MrCATIA

Super Moderator
Comparing 21 to 533.4 equals 25.4, which indicates a problem with units. (21 inches = 533.4 mm)

Check the Tools + Options and make sure the length units are set to mm, and verify the DXF units also (mine is set to Automatic). see both attachments

units.JPG units dxf.JPG
 
Last edited:

MrCATIA

Super Moderator
If this only happens rarely, I would suspect the dxf files. Do they open okay with other software? Were they created differently?
 

PetriT

New member
Hi,

And thanks for answers and suggestions. I will check those things later today.

Indeed, this happens randomly with simple shapes. If I add more stuff into the file it saves it normally and opens it normally.
I have checked those dxf-files with online dxf-viewer and there they appear in wrong scale there too. Every file is created same way and problem is only with simple shapes.

...
I checked the options after every step when creating dxf file. Didn't notice any changes there during the process.
After changing option under "dxf"-tab from automatic to mm (millimeters) saving did work correctly. I think the problem was there. Just weird that it is only with few files (few newly created and some older ones).

Anyway. Now I know the way around the problem and I can continue my project. Thank you!
 

MrCATIA

Super Moderator
One more thing to verify:

Make sure the dimension units are correct. Use the NUM.DIMM dimension style for millimeter dimensions. Use the NUM.DINC style for inch. (or equivalents)
 
Last edited:

Sponsor

Top