Welcome to 3DCADForums

Join our CAD community forums where over 25,000 users interact to solve day to day problems and share ideas. We encourage you to visit, invite you to participate and look forward to your input and opinions. Acrobat 3D, AutoCAD, Catia, Inventor, IronCAD, Creo, Pro/ENGINEER, Solid Edge, SolidWorks, and others.

Register Log in

3D Shading Issues

Zero3

New member
Can anyone help me? I am just starting to get into 3d models and i am having trouble when i do a gouraud shade there are spots where the walls get jagged. Not sure what im doing wrong.
 

support

New member
Edges or faces?

When you say jagged, do you mean at the edges of the walls or in middle of flat walls? For edges, see if there is a setting called "antialiasing" and if there is, turn it on. The jaggies along edges during shading is called aliasing. This setting will smoothe them out. If they are in the middle of flat walls, that's another matter entirely.

3DCADTips Help Desk :cool:
 

Zero3

New member
edges

I cant find the option. What menu is it under? And my problem seems to be where walls connect or where other 3d objects meet up to others.
 

Steamineagle

New member
Hello Zero3,

This effect may be due to the fact that 2 solids intersect.
Take for instance where two thick walls meet at a corner.
Each wall is in effect a tall rectangle meeting at right angles.
At the corner you will get this ragged or bleeding effect for the extent of the width of the walls.
This is where, mathematically, you have two faces occupying the same space.
From what I understand it may be better to have these two walls as two separate entities for rendering purposes.
However, to get round this bleedin' problem what you do is chamfer the meeting corners of each wall at 45 degrees, like a picture frame.
What happens with other shapes..I dunno.
What sort of shapes are you working with....dare I ask!!;)
Does this help?
Best of luck.

regards

Stephen
 

Sponsor

Top