Welcome to 3DCADForums

Join our CAD community forums where over 25,000 users interact to solve day to day problems and share ideas. We encourage you to visit, invite you to participate and look forward to your input and opinions. Acrobat 3D, AutoCAD, Catia, Inventor, IronCAD, Creo, Pro/ENGINEER, Solid Edge, SolidWorks, and others.

Register Log in

Assembling parts with refernce to assembly reference planes

S

sudhi_kak

Guest
Hi Guys,

I am not able to assemble any part with reference to the Assembly reference planes. The assembly reference planes do not get highlighted for selection when I try to assemble any part with reference to them (e.g. Mate or Planar Align). However I am able to assemble the first part in the assembly, taking assembly planes as reference. Please let me know if there is any option settings to be done to enable assembling any part with respect to the assembly reference planes.
 
W

William B

Guest
Two "cheating" ways

Hi SK,

I have had the same problem. I wanted to create a 3D machines layout.
I can not be of much help - other than 2 cheats.;)

1)
Use the virtual functionality of SE V18.
I have not used it myself other than the tutorial.
Maybe someone like our resident expert Andrew can help here.
(we should actually start a tip/post on this virtual functionality)

2)
create a refference part that takes up the place of the planes.
Place that first, and refference all others to that. :eek:
This "dummy" part can be minutely small and thin - or simply hide it later.

I am sure than is something more straight forward.
I thought however I will answer you so long.
I will ever ask my office buddies later today. :eek:

GERT - do you know how to solve it - or simply where to look for an answer?

Thanks,

WB
 
K

ksudavid

Guest
SK,
What Version and Service Pack are you on. I have never encountered the problem you are having. Can you select the planes from the Edgebar? Did this problem just start?
 
W

William B

Guest
SK,

"ksudavid" has very valid questions.
After reading his post I simulated your problem -
I put down two parts positioning it to the planes, as if edges of another part.
I had no problems what so ever.

I have seen / experience your problem before though but do not know when - maybe SE V17?
I am currently running SE18 SP5.

Also repeating the above questions:
1) what SE version and service pack do you run?
2) can you see your XYZ planes in your assembly enviroment?
3) can you see and select the planes from your edgebar?
4) have you tried auto connection function yet?

Otherwise the use of a fictional part can be used.
I use this technique and fictional edges alot if I need to do something in a hurry and it is for visual effect only (impressing a customer).

PLEASE give us feedback - even if it helped or not.
(It is also helpful for us if we know that we can close down a post.)
Hope to hear from you soon. :)

"ksudavid": thank you for contributing. Hope to "see" you soon & regularly.

Andrew: it is a valid point; we should make it standard for people to specify which SE version they are running, when posting a question.

JK: Have you come accross this problem before too?

If something is only for visual pressentation, my friend call it "eye candy"

WB
 
Last edited:
S

sudhi_kak

Guest
Assembly reference planes

Hi All,

Sorry for not introducing myself in my first post. I am sudhir and I am working for Ingersoll Rand ( I have been working on SE since last 6 months)

The version we use is SE V17. (I dunno what service pack we run, I can get that info from our IT guys) I am not sure if V17 has got the Virtual functionality..so I dint try that, though the idea of creating a dummy first part and using its planes as reference for other parts really did work. Thank you for that.

To answer the other questions...
- The XYZ planes are visible, but they wont let them to be picked for selection and this problem has been there always
- I am not able select the planes from the edgebar too..
- I am not aware of the autoconnect function

I guess there should be some other direct means to solve this problem, if it is not an inherent bug in SE V17 or earlier versions...!!

Sudhir.
 

maddddog

New member
Welcome Sudhir,

since everybody else is having this problem I thought I would try it. Let me see if I understand correctly.
I opened and assembly, brought in the first part and it is grounded in the middle of the xyz assembly planes, then I brought in the second part, selected a face and mated it to an assembly plane, no problem.

Did I miss something?
JK
 
W

William B

Guest
Dear :) Sudhir,

No worries - you do not have to tell us who you are and where you work.
We prefer not knowing.
We help regardless of who you are - reducing cultural and political boundaries.
It helps us though if we know what version software and PC type you use.

Madddog (JK) will be able to help much better.
He is running the same software version you have - although not the same update version I think.
>> anyone else with V17 - SP1 or less?
Please explain to Madddog again in more detail (general terms - not giving away your design, only the intention) what your problem is.

Also tell us which service pack please.
You can get to the full version number if you go to HELP - ABOUT.
Write this number down and post it on the forum.
We will determine your update from this number.

However find out if you IT admin guy do not have a "service pack update" stored somewhere.
Normally they will get it from a website and store it away on their database.
If not - let me know by private message and I'll try to help you by latest Tuesday with a web address.

I am glad the fake object idea works.
The virtual idea won't work on V17 though, I think.
- Have you worked through the SE tutorials yet - you should.
If we do solve your problem - do us a favor, contribute to some elses' need too.
Be an active member please.

JK: thanks for your reply.
which service pack do you have?

Your :) CAD friend,
WB
 

maddddog

New member
Hello Sudhir,

Sure, you can ask me anything. If William thinks I can help you........then maybe he is right. Maybe he is wrong for once, we'll see.;)

You have been using SE for 6 months, what did you use before?

I am one of the older new guys he was talking about. I have been using SE for about a year and a PC for about a year and a half. I was trying to live without developing computer skills but I gave in. Now I am a computer maniac, but I still have a lot of questions myself. I do love solid modeling. It was the missing link in my process of taking something from concept thru prototype to production.

William, I will find out next week what service pack we are using.


JK
 

andrewyipko

New member
Hi Guys,

Sorry for my late arrival; have been busy; will continue to be very busy for coming weeks.

I believe this is a bug in V17. I've come across it myself previously. You may want to have your SE V17 upgraded to Update 14. This is the latest patch for V17.

Regards,
Andrew
 
K

ksudavid

Guest
sudhi_kak,

Take andrewyipko's advice and upgrade to the latest service pack. I found this PR in the V17 service packs:

"PR 2055978: Fixes a problem with being able to locate an assembly reference plane in FlashFit"

Two things you might try. First, do not use Flash Fit mode when assembling. Instead us the acutal planar align relationship. Second, make sure Reduced Steps is turn off. I've attached an image showing where to turn off Reduced Steps.

David
 

Attachments

Sponsor

Top