Welcome to 3DCADForums

Join our CAD community forums where over 25,000 users interact to solve day to day problems and share ideas. We encourage you to visit, invite you to participate and look forward to your input and opinions. Acrobat 3D, AutoCAD, Catia, Inventor, IronCAD, Creo, Pro/ENGINEER, Solid Edge, SolidWorks, and others.

Register Log in

Remove edges in a Join Surface

Hello All,

First of all thank you for accepting me here :).
I´m Roger and I work using Catia.

I have a problem with some surfaces.

In a first instance i have create 4 sweep surfaces.
After I join them ( with: simplify, check connexity and ignore erroneous elements)
So I get a join surface where i can see still the 4 different surfaces.

I would like to remove the edges of the old sweep surfaces, I have tried several things but nothing works for now :(


surffaces.jpg

thanks in advance!
Roger.
 
Last edited:

MrCATIA

Super Moderator
Hello Roger,

When you Join the surfaces together, there is an option for Federate. If you choose the Federate All option, the joined surface will be treated as a single surface.

Another option is to Copy the Join surface and Paste Special As Result.

Of course, you want to change the Render option to Shading Without Smooth Edges
 
Last edited:
Hello Roger,

When you Join the surfaces together, there is an option for Federate. If you choose the Federate All option, the joined surface will be treated as a single surface.

Another option is to Copy the Join surface and Paste Special As Result.

Of course, you want to change the Render option to Shading Without Smooth Edges
Hello MrCATIA,

thanks for the reply!

I tried the option to Federate, after it the "selection" works on the complete surface correctly, but the edges are still shown. Unfortunatelly I can´t change to "shading without smooth edges", the surface has to be without edges (requirement) because when i build a 3D out of it, then the edges come also to the 3D part.

I could do the copy-paste as result, but it still does not solve the problem...
 

MrCATIA

Super Moderator
The surface edges are only for visual effect, and they should not affect the 3D solid. If you don't want to see them, choose a different Rendering option, or customize the Rendering to meet your requirements.
 
Last edited:
You are completely right. My 3D is perfectly right in terms of shape. But that is for the Aerospace Industry and these are the standards.
As I have to deliver the part to my customer, I can´t control their settings and so, I must solve that somehow.
 

MrCATIA

Super Moderator
Roger,

When you first made the Join surfaces, did you check for tangent continuity between the surfaces? If the surfaces are not tangent to each other (not smooth), there will be an internal edge between the surfaces.
 
Last edited:

Sponsor

Top