Welcome to 3DCADForums

Join our CAD community forums where over 25,000 users interact to solve day to day problems and share ideas. We encourage you to visit, invite you to participate and look forward to your input and opinions. Acrobat 3D, AutoCAD, Catia, Inventor, IronCAD, Creo, Pro/ENGINEER, Solid Edge, SolidWorks, and others.

Register Log in

Resetting system variable

Appollo

New member
Hi,
I have changed my fieldeval and updatethumbnail system variables to 21 and 0 to help with performance issues in drawings with a lot of attributes and fields. For some reason those keep changing back to their original settings fairly often. They do retain that setting for a little while and at some point change. Any suggestions?
Thanks in advance.
 

Adesu

New member
Hi Apollo,
Use error handling like this code
Code:
(defun c:test (/ *error* om otm opt)
  (setq *error* myer)
  (setq om (getvar "xxx"))  
  (setvar "xxx" 0)
  (setq otm (getvar "yyy"))
  (setvar "yyy" 1)

  (setq opt (getstring t "\nPress Esc button to test error: "))
  ;*****PUT YOUR MAIN CODE HERE *******
  
  (setvar "xxx" om)
  (setvar "yyy" otm)
  (setq *error* nil)
  (princ)
  )

(defun myer (msg)
  (setvar "xxx" om)
  (setvar "yyy" otm)
  (setq att "*** Resetting system variable has been done ***")
  (princ att)
  )

Hi,
I have changed my fieldeval and updatethumbnail system variables to 21 and 0 to help with performance issues in drawings with a lot of attributes and fields. For some reason those keep changing back to their original settings fairly often. They do retain that setting for a little while and at some point change. Any suggestions?
Thanks in advance.
 

Agostino

New member
Hi,
The reason may be that some application you have in AutoCAD that does not restore the
settings after changing them. I suggest you to force them by creating a file named acad.lsp in one of your support file search path and add these rows below to it using Notepad.
(setvar "fieldeval" 21)
(setvar "updatethumbnail" 0)
Cheers!
 

Sponsor

Top