Welcome to 3DCADForums

Join our CAD community forums where over 25,000 users interact to solve day to day problems and share ideas. We encourage you to visit, invite you to participate and look forward to your input and opinions. Acrobat 3D, AutoCAD, Catia, Inventor, IronCAD, Creo, Pro/ENGINEER, Solid Edge, SolidWorks, and others.

Register Log in

SW issue in assembly when trying to insert a part

91shelby

New member
SW 2007 keeps giving me this error "the component could not be added to the assembly at this location as it would go beyond the modelers resolution"

Any ideas? it also when i try to rotate zooms waaaay out.
 

Wayne Grabley

New member
component could not be added to the assembly at this location - FIX

I am running Solidworks 2016 and I also had the same error, but I also had nothing showing on the screen. The tree still had all the parts, but nothing was there. I called my Solidworks support company and the gentleman said he never seen anything like it (we did a screen share on the internet). We figured out that a cad model I got from a vendor had errors. Find the parts you did not draw, which were most likely not drawing in Solidworks and run the “Import Diagnostics” for it. What I found was the part had "Faulty faces" and "Gaps between faces". This is exactly what I did in order (which you don't have to do exactly, but this is what I did): 1. delete "Bad" from the assembly 2. save and exit the assembly. 3. Open "bad" part, run “Import Diagnostics”, then save and exit part. 4. re-opened the assembly and re-insert the “Fixed” part. 5. save and exit the "Fixed" assembly. 6. re-opened the “Fixed” assembly and it "Should" be fixed. It worked that way for me......that's why I registered to 3dcadforums (I did not find this looking on the internet, but this fixed it........so I am sharing what I learned.) If you need more info you can contact me.
 

Sponsor

Top