Welcome to 3DCADForums

Join our CAD community forums where over 25,000 users interact to solve day to day problems and share ideas. We encourage you to visit, invite you to participate and look forward to your input and opinions. Acrobat 3D, AutoCAD, Catia, Inventor, IronCAD, Creo, Pro/ENGINEER, Solid Edge, SolidWorks, and others.

Register Log in

Unable to unload document

vsawye2

New member
can anyone tell me why when switching from design to visualization mode on some of the parts i get this warning "unable to unload document ... ". it seems to be a random thing, and how to fix it? thanks for any help.
 

MrCATIA

Super Moderator
I've tried to duplicate your problem, but unable to. Which release are you running?

My guess is there is something that is "locking" the part into the design mode, that prevents you from switching to Vis mode. Is the part open in another window? Have you made changes to the part?

If you close the product and re-open it, is the part in Vis mode when the product is first open?

Does the part symbol in the Product Tree appear different from other parts?
 

vsawye2

New member
MrCATIA,
i'm running R14 service pack 3 on a Sun box.
Typically this is how it all happens.
1) i'll open the top most assembly.
2) then i usually need to work on a part or subassembly in that assembly, so i right click on it and open in new window.
3) if its a subassembly, then i'll do the same until i get down to the part level and do my changes.
4) when finished changing the part, i'll save it and close it, which then takes me to the assembly that it is in.
5) i'll make sure that assembly is updated, and then save and close it.
6) which typically takes me to the top assembly level, which i update and save.

this is usually where the problem occurs, i'll have parts down in the assembly heirarchy that wont switch over to visualization mode, and not necessarily parts that i had been working on.
if i close the assembly, then reopen it, i get the same result. but, its not always the same parts from day to day. i could be doing something wrong, not sure, i try to be careful to make sure everything is updated and saved before i move up the heirarchy.

its not a show stopper problem, but annoying none the less.
 

MrCATIA

Super Moderator
Your 6 steps sound like you're doing everything OK. Nothing unusual at all.

The parts that are giving you problems: do they contain External Reference links to other parts? Could these parts be child parts that have been effected by the changes you made to their parent geometry in the other parts?

Looking at the Spec Tree of the assembly, what color are the icons in front of each part?
 

hlee73

Newbie
can anyone tell me why when switching from design to visualization mode on some of the parts i get this warning "unable to unload document ... ". it seems to be a random thing, and how to fix it? thanks for any help.
Hi, vsawye2,
Has your issue been resolved? How? I just found I have the same problem and don't know how to fix it.

Harry
 

Sponsor

Top